Disabled the "Away" feature.

Discussion in 'Announcements Archive' started by Crayo, Dec 27, 2011.

  1. It was causing an error on the post_bit, so until we figure out why it will be disabled.
     
  2. @[Anonymous] - Fix it.
     
  3. RT @Anonymous - fix it. #needhelp

    @xanth @crayo fixed while mobile browsing like a ninja. Still need to make a postbit away background though. #callanonymous #jobdone.

    P.S. @Crayo, you post too much, took me ages to find a post by monster. #postwhore #fml
     
  4. Nice twitter theme.

    Learn 2 tag though @[Anonymous]
     
  5. ic @[Crayo], gna make tagging thing show message in PM though, save clicking link or if post gets edited/deleted.


    Fucking edit button is so hard to click on this ****ing phone.
     
  6. Lmao when you edit it, I get another PM. :mad:
     
  7. What's the error?
     
  8. I can't remember now, in his post_bit it had like a line of code and his username in-between. Naturally that stretched his post_bit out and looked horrible. Probably one character missing from the code that's all, just haven't looked into it now.
     
  9. If you enable it again, I can see the problem.
    To prevent the postbit from stretching, just add a div tag like this to postbit_classic surrounding {$post['user_details']}

    Code:
    <div style="max-width:150px;"> </div>
    150px looks about right for this theme.
     
  10. Forgot this was already fixed by Anon. Feature should be available to use now.
     
  11. I can see you're using the div tag, but with awards installed it didn't work correctly, surrounding everything in postbit_author_user should work.
     
  12. Fix dat regex @[Anonymous]

    <snip>

    PM Anonymous directly for this

    -Crayo
    __________

    I can't PM him directly because you fucking took away the screenshot

    *is not going to do it now*
     
  13. The problem had nothing to do with long text.

    To make the table display a different background depending on the users online status, i placed the user status template variable inside the class attribute of the tr tag surrounding the whole user area in the postbit. Then replaced the online and offline templates with status_online and status_offline respectively, then simply styled those classes with a different background image.

    I assumed the away status didn't show up in the postbit, and simply forgot to edit the template. The default template returned HTML and broke out of the tr tag above, which is why some plaintext html was shown.

    When I get back onto the computer, I just need to make a separate background for 'away' and it'll be done.
     
  14. I'm sure I never had these problems with this theme.
    {$post['onlinestatus']} is already inside <tr> btw.
     
  15. You misunderstood. I moved that template variable inside <tr class="{$post['onlinestatus']}">*, so now, whichever template is returned, the tr will be styled with either the status_online or status_offline class.

    I've now changed the away template to return status_away, now I just need to make a background image under the style .status_away.

    * you know how hard it was to write that on a mobile?
     
  16. I sure do, I'm on mobile right now too.
    There's still an alignment problem in the first post of each page. Author -- Message
     
  17. I see, I might just remove that part later anyway. It should be pretty obvious what the two columns represent without needing column headers.
     
  18. Just an FYI, when quoting a user you will get a regex error in the header.

    You'll see the problem, I can't obviously I'm not server side.
     
  19. What specific post were you quoting when you got the error?
     
  20. All posts, crewcode plugin, preg_match - empty regular expression on line 61.
     

Hide